AnsweredAssumed Answered

SWX 2018 on Surface Book

Question asked by David Serrell on Nov 22, 2017
Latest reply on Nov 27, 2017 by David Serrell

I have recently installed SWX 2018 on a Surface Book (16Gb; NVIDIA card).  Initially, it ran ok (small graphics glitch that I won't get into).


Recently, it does not run at all.  I had the same problem when installing and running 2016. The program starts normally but when it gets to the flash screen that says, "Verifying license . . . ." it simply goes away and nothing else happens.


Here are the steps I took to get my 2016 to eventually run:


1)  Full uninstall of SWX

2)   Reinstall w all virus protection turned off

3)  Go into Services and set all licensing to "Automatic"

4)  Restart, turn on all virus, etc.

5)  it worked



I did all of this on SWX 2016 and it worked.  It is not working on SWX 2018.  Extremely frustrating.  As I mentioned, it was working fine.


In addition to the above, I also attempted to go back to an earlier restore point.  This did not work.


I also did a full uninstall, then, went into the registry and killed all folders associate w Dassault, FlexLicense etc.  Did a reinstall.  Nothing.


I know the official company line is that this computer is not supported.  However, it was running fine.  Both 2016 and 2018.


Anyone seen this?  I have been in contact w support and they can't help me.


EDIT:  On SWX 2016, when it did run, it first displayed an error indicating swactwiz.exe was unable to start correctly.


UPDATE: I can run swactwiz manually.  It confirms my license is activated and operating correctly.  I set it to run as admin.  I also did this to SWX 2018.  I then ran compatibility mode on both.  None of these fixed my problem.


UPDATE:  Still having this issue.  A little surprised no one has commented . . . .


I found this thread w the same problem I am having.  Not clear what the resolution was:

Windows 10 Enterprise, SolidWorks 2016 SP0. Splash launches, but app doesn't load.