8 Replies Latest reply on Mar 23, 2017 4:02 PM by John Pesaturo


    Dan Fowler

      After creating a dxf file, I cannot create a new drawing/part/assembly file.  I have to close Solidworks completely down, and restart it.  Does anyone have this issue?  It started in Solidworks 2016 SP5, and has continued in Solidworks 2017.

        • Re: DXF
          S. Casale

          There are no hidden dialog boxes that pop-up behind SW?

          • Re: DXF
            Brett Menze

            Yes, that happens to me too.  Must be a bug.  Come on SP3!

            I did notice though, that you can open an existing file and then close that file.  Then new, part, works again.

              • Re: DXF
                Jim Wilkinson

                Hi Brett and Dan,


                As Scott says, please do make sure you report this to your reseller and work with them to get a reproducible case (since I've tried it based on your posts and have not been able to reproduce it). It has been reported into our SPR system, but was not reproducible internally with the information provided so far, so your help in getting a reproducible case to your reseller is appreciated so we are sure to fix it. Also it's always important to report your exact case, unless it is completely obvious it is the same exact issues. Even though the two of you are seeing it, there is always the potential that there are variations in what you are doing/your setup and without reporting it, you'll be disappointed if your specific case of the problem is not addressed. Always better safe than sorry as they say!




                • Re: DXF
                  John Pesaturo

                  Yup, that's a funny one. I didn't even know it was an issue until I tried to replicate it. Same here, SW2017 SP2 ...


                  Good findBrett, opening an existing file allows the user to create a new part/assembly/drawing without rebooting.

                • Re: DXF
                  John Pesaturo

                  Dan, I was able to fix that issue on my computer but it required some things that honestly I wasn't really comfortable with and fixed it with my VAR over the phone/Go-To Meeting style.


                  Essentially, we had to delete my registry for SW so that it considered our SW2017 update as a fresh install. What was happening was it had pulled so many versions of the "Copy Wizard Settings" forward over the years that it was FUBAR. What gave it away to the VAR was that when we tried to replicate the issue, I had a box that popped up during the DXF save that showed line colors/styles and such. The VAR noticed that it was something he hadn't seen before but I have always seen it. (We've had SW since 97+) Once the registry was cleaned out the box never popped back up and my DXF issue was fixed. The downside being I have no idea how many times I've had to fix settings over the past week that I never knew had been changed ... LOL