10 Replies Latest reply on Feb 7, 2017 8:37 AM by Jonathan Burt

    Suppressed component visible in drawing

    Jonathan Burt

      I have an assembly file with 3 of the components suppressed, but they are visible in the drawing. Any ideas on how to fix this? I made sure the configuration in the drawing matched the assembly configuration that has them suppressed and made sure the components were suppressed in the feature manager in the drawing.


      Thanks in advance,

        • Re: Suppressed component visible in drawing
          Deepak Gupta

          Make sure that all projected/child view are either using the same config as parent view OR link to parent view.


          And also make sure the components are suppressed and not hidden.

          • Re: Suppressed component visible in drawing
            Glenn Schroeder

            That's a weird one.  I assume you've tried a Ctrl+V rebuild, and that didn't fix it?  You might also try copying and pasting the drawing view, or the whole sheet, to see if that will fix the problem.

            • Re: Suppressed component visible in drawing
              Jonathan Burt

              Ryan, "When you make a new drawing an put a view from this assembly in it is the issue still there?  Does this happen with other assemblies and their drawings or just this one?  Could just be that drawing."        I started a new drawing and the components don't show, even when I start a new tab in the current drawing the components don't show. If I project the current view, they don't show. If I change the "display style" they don't show. It seems to only be a problem in this one view/display style.


              Deepak, The "Link Display State" box was unchecked. I tried checking it and rebuilding, but they still show, so I unchecked it again and they still show.


              John, The components were suppressed, which I think means they should be hidden anyway. I tried right-clicking each component and selecting "Hide" but they are still shown. As a side note, if I try to select the component in the drawing view it selects whatever surface is behind it. Its like SW doesn't realize recognize the component is there.


              I sincerely appreciate you guys offering suggestions but I think we have to chalk this one up to a bug.