1 Reply Latest reply on Nov 10, 2016 8:57 AM by Manfred Amoureux

    DraftSight on Linux crashes at startup

    Manfred Amoureux



      I have installed the latest version of DraftSight on my computer, running Linux Mint 17.3.

      Whenever I try to open DraftSight, I have the window asking to activate the copy of DraftSight (which is normal). I choose 'activate now', fill the form, have another window with "Please reactivate the product to continue using it". Up to there, it is similar to what I had installing DraftSight on Windows. But when I then click 'ok' , DraftSight crashes completely and instantaly.

      I have tried about a dozen times and got the same scenario every time. I have not received an activation email on my email address.


      I wish I could have a look at the logs but don't know where they are.


      Any idea how to solve this or at least diagnose the problem better ?

        • Re: DraftSight on Linux crashes at startup
          Manfred Amoureux

          It seems I got it working :

          I uninstalled Dratsight using Synaptic and choosing 'complete removal' and installed it again.

          This time, when I tried using it, it showed a different error about not having write rights on the files in ~/.config/DraftSight.

          I fiddled with it and changed the permissions and ownership of the files with the command :

                 sudo chown -R your_username:your_username *

          It seems to be working now.