AnsweredAssumed Answered

Cannot Install Solidworks 2016. Next Button not working on Installation screen

Question asked by Chris Dustbin on Sep 17, 2016
Latest reply on Jan 3, 2017 by Deepak Gupta

I have windows Home Premium SP1 on a laptop.


I have been trying to install solidworks 2016 as previous versions have worked.


it opens the welcome page but when I pickn individual installation and next nothing happens


Note things Ive read and tried.......................@@@


The old elments I couldn not find a uninstall option so tried clearly out all reg, programme data, windows folders, program folders etc of any solidworks components clearly marked.

ive reset Internet exploer.


Tried the compatibility option when right clicking on theset up file settign it to windows 7 then unclicking the box.


Done the

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\

with pseudo-graphic number, you'll see it before zone number 0.


thing... there were no letter



Done the

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\0

3.      In the right pane, right-click 1200, and then click Modify.

4.      In the Value data box, type either 1 or 0 to overwrite the existing value of 3. Then, click OK.






The UAC if off, no anti virus


Done the



Open a command prompt or run command:  regsvr32 jscript.dll


2. Try restoring Internet Explorer® settings:

Open Internet Explorer >Tools >Internet Options >select ‘Advanced’ Tab > select “Reset…” button.

Launch Installation Manager and see if the next button can be selected or not.


Saw this

So I found a guide that auggy posted here


which had me check a registry entry for vbscript.dll.  My registry entry HKEY_CLASSES_ROOT\CLSID\{B54F3741-5B07-11cf-A4B0-00AA004A55E8}\InprocServer32

the registry had no CLSID folder




Any other suggestions?