1 Reply Latest reply on Nov 5, 2015 3:06 PM by Patrick Malone

    Dual Dimension Not Displaying As Desired...

    Patrick Malone

      This is a recorded macro (I know... I know...)

      Solidworks 2013

       

      I want to turn on Dual Dimensions and have them appear to the right.

      When I run this macro, for some reason they show up formatted TOP.

      Here is what I have...

       

      = =

       

      Dim swApp As Object

       

      Dim Part As Object

      Dim boolstatus As Boolean

      Dim longstatus As Long, longwarnings As Long

       

      Sub main()

       

      Set swApp = _

      Application.SldWorks

       

      Set Part = swApp.ActiveDoc

      boolstatus = Part.Extension.SetUserPreferenceToggle(swUserPreferenceToggle_e.swDetailingDualDimensions, swUserPreferenceOption_e.swDetailingDimension, True)

      boolstatus = Part.Extension.SetUserPreferenceInteger(swUserPreferenceIntegerValue_e.swDetailingDualDimPosition, swUserPreferenceOption_e.swDetailingDimension, swDetailingDualDimPosition_e.swDualDimensionsOnRight)

      End Sub

       

       

      ps: When I go into Options -> Doc Properties -> Dimensions

      Everything is set correctly.

       

      As an addendum, this is to change an existing drawing that was formatted with only IPS units.

      We were instructed to change every existing drawing to Dual Display.

       

       

      Please advise..

        • Re: Dual Dimension Not Displaying As Desired...
          Patrick Malone

          I also found this

           

          Dual Dimension Macro

           

          Dim swApp As Object

          Dim Part As Object

          Dim SelMgr As Object

          Dim boolstatus As Boolean

          Dim longstatus As Long, longwarnings As Long

          Dim Feature As Object

          Sub main()

           

          Set swApp = Application.SldWorks

           

          Set Part = swApp.ActiveDoc

          Set SelMgr = Part.SelectionManager

          Part.SetUserPreferenceToggle swDetailingDualDimensions, True

          Part.SetUserPreferenceIntegerValue swDetailingDualDimPosition, swDualDimensionsOnBottom

          End Sub

           

          = = =

          Changed this:

           

          Part.SetUserPreferenceIntegerValue swDetailingDualDimPosition, swDualDimensionsOnBottom

           

          to this

           

          Part.SetUserPreferenceIntegerValue swDetailingDualDimPosition, swDualDimensionsOnRight

           

          I still get the dual dimension formatted TOP... (one on top of the other)

          My settings in SW are what I desire but it's not showing up that way..

           

          Dual Dim Display - Checked

          Right Radio Button - Checked