AnsweredAssumed Answered

Is anybody else having issues installing Solidworks on windows 10?

Question asked by Andy Birmingham on Aug 20, 2015
Latest reply on Mar 14, 2016 by Glenn Schroeder

Okay, so I got the notice to install windows 10 in early August and didn't see much or any serious issues aside from some stability issues (or things that came from not running as administrator); so I proceeded to install and upgrade to windows 10.


Solidworks is the ONLY program to have stopped working. Completely. Crashed on startup. (An error about a missing component or service I think) The downloader tool still works and i tried upgrading to Solidworks 2016 Beta SP2, but it didn't fix the problem, it wouldn't even complete the install.


So i ended up completely un-installing (aside from the serial key entry) and then attempting to re-install. This also failed, at about 20% completion it gave this exact error:


" Internal error: The Windows Installer for this product component did not run as expected: register_i386_SldShellExtServerExe "


It gives the option to cancel installation or to attempt to continue. If you attempt to continue the installation it gives a "Fatal error" and you go to the end of the install window with "These items were not installed correctly".


I have tried Solidworks 2015 SP3/4 and Solidworks Beta 2016 SP2/3 (3 just came out, and still no dice)




So what gives? Is this an issue with anybody else? I have tried following Javelin Technologies uninstall guidelines but they all seem to use the solidworks "installation manager" which is not there since it was fully uninstalled. Would going into the registry to remove the registry keys help at all? Solidworks says that windows 10 support will come as-of 2015 SP5, which from what I read won't be out until October.... I'm really hoping to get back to using it sooner than that.


As for Windows 10 and rolling back to 8.1? I tried that the first day I installed windows 10 after a few issues, and it didn't work, so I ended up working through the issues. The rollback tool is useless.