5 Replies Latest reply on Mar 5, 2015 11:00 AM by Jamie McDonald

    Context toolbar keyboard shortcuts

    Jamie McDonald



      I've noticed that in the context toolbar if you hover your mouse over certain of the icons particular letters are underlined as if they are keyboard shortcuts. For example if I left or right click on a part in an assembly and then hover my mouse over the edit part icon the tooltip 'Edit Part' appears. The 'a' of part is underlined suggesting to me that there should be a way of selecting this icon using 'a' on the keyboard.


      Despite this I can't find any way to actually access the shortcut. I have tried pressing 'a', 'alt+a', 'shift+a' etc on both left and right mouse clicks. I've also tried changing the context toolbar settings in 'customize' but nothing seems to work. Can anybody help?


      Thanks in advance!

        • Re: Context toolbar keyboard shortcuts
          Ingvar Magnusson

          You can make a shortcut for it, see image.



          • Re: Context toolbar keyboard shortcuts
            Jim Wilkinson

            Hi Jamie,


            Do you have any specific examples that you can show a screenshot of? There is no functionality to be able to use keyboard navigation to the context toolbar buttons; this only works for the shortcut menu below the context toolbar that you get with the right mouse button. There could be a bug where the underlines show in the tooltips unintentionally, but I haven't been able to reproduce the problem so an image would help.


            As Ingvar states, the best way to access commands through the keyboard is a direct shortcut key to the command itself. I know this won't work for all of the things in the context toolbar since many of them are are contextual based on the selection and therefore aren't available in the customize dialog.


            I hope this helps,


              • Re: Context toolbar keyboard shortcuts
                Jamie McDonald

                Many thanks both of you. Jim, sounds like it may be just a bug and as you say some of the options I had in mind aren't available in the customize list.


                Here is a screenshots to show you what I mean:


                I've just tried to replicate with other icons and it's only the 'Edit part' that comes like this which lends credence to it being a bug.


                Can I ask one other question - in the context toolbar as shown above some options in the toolbar have underlined letters such as 'M' for 'Make Virtual' which correspond to shortcuts. However if the context toolbar setting 'Show in shortcut menu' is unchecked within customize the shortcuts still work but the letters are no longer underlined. Is there any way to prevent this from happening?


                Thanks again