2 Replies Latest reply on Feb 23, 2015 5:58 PM by Clint Hudson

    SolidWorks Add-In won't load

    Clint Hudson

      We have an Add-In that we initially developed many years ago.  It has worked flawlessly until recently.  I found the cause, but am confused as to what happened.


      We created a branch of our development folder, and the Add-In from the new branch will not load.  It shows up in the Tools/Add-Ins list, but neither box is checked. 


      Using our source control system, I compared the swAddIn.vb file from the previous branch to that from the current branch and there's no change.  If I build the Add-In from the previous branch and then run the Add-In from the current branch in debug, SolidWorks will open and our Add-In will load, but it will load the version from the previous branch, not the current one.


      As it turned out, I had added a script in the post-build events prior to registering the Add-In.  The script copied in several documents that are referenced by the application, and may take as long as 10 or 15 seconds to run.


      With this script running before the registration event, SolidWorks would not recognize my Add-In.  Why is that?




        • Re: SolidWorks Add-In won't load
          Christoph Neundorf

          Hi Clint,


          I had a similiar issue when the Add-In was searching for a file that could not been found at the location specified.

          In my case i used a XML file to store user settings. I hope this info might help you.




            • Re: SolidWorks Add-In won't load
              Clint Hudson

              When I ran the script after registering the Add-In, everything worked like it should.  I'm wondering if there was some sort of time-out for the post build events, and if one of the events took too long it would go ahead and complete the build and start SolidWorks with the product unregistered.  The files that my script copied in are dependencies of dependencies.  Without which the software won't run properly.