5 Replies Latest reply on Jun 13, 2014 2:41 PM by Matthew Peterson

    Opening Assemblies Suppressed

    Alex Thompson



      I am running Solidworks 2013 on a newer computer.  I have a problem where whenever I open an assembly, all the components are suppressed.  Not only are the parts and sub-assemblies suppressed but solidworks also can't find their references.  If I do find references, all the parts are listed out with correct references but I have to go an manually find all the parts and it takes forever! Has anyone dealt with this before?

        • Re: Opening Assemblies Suppressed
          Deepak Gupta

          Welcome to SOLIDWORKS forums Alex.


          There are other people who have reported similar problem, so please report to your VAR to investigate.


          Can you try opening the assembly in Design Review Mode or Lightweight to see how assembly components reacts with that.


          You might also find this post helpful for your future reference.

          • Re: Opening Assemblies Suppressed
            John Burrill

            Alex, I've seen something like this in SolidWorks 2013.  I run a side-business and on my machine at home, I have SolidWorks 2013 SP1EV.  I'd open an assembly and get notices that certain amoung the parts failed to load, usually components of subassemblies.  I run CA Antivirus and when I'd check an assembly tree out of the vault, it would step on the sudden appearance of files in my hard-drive rendered there by a background service and interupt SolidWorks during open.. 

            Excluding my workspace directory from the virus scanner was the solution to that issue.  I don't have the problem at my day job where we use Kapersky and SW14 with the latest service pack.  So the issue could still be specific to 2013.

            There's also a possibility that this is a settings issue.

            What will happen when you open an assembly is SolidWorks will either look for components in the file paths stored in the assembly model or it will use an algorythm coupled with a system level search path to look for files.

            What it sounds like in your situation is SolidWorks is set to look only in the file locations stored in the assembly file and that your assembly tree is in a slightly different location-like you moved all of the files into one folder, or youir parts are in a subfolder of your assembly file.  So while it's very easy for you to locate those files individually, SolidWorks misses teh obvious and doesn't load them.

            The Solution in this case is to go into Options: System Options tab, External References panel and check: 'search file locations for external references"

            Then SolidWorks will look for each component in your assembly folder, or in a subfolder of the that has a path similar to the one stored in your assembly and about 12 other places to find the file.

            The worst case scenario is that you have to add the assembly folder and each of the subfolders to a file search path-which is where SolidWorks will check first to locate files.

            If you're in a situation where this is the only thing that works, then you should get PDM software to help with file management.

            • Re: Opening Assemblies Suppressed
              Matthew Peterson

              Are you a regular user of lightweight mode?

              I've seen similar issues, and it seems to be related to lightweight mode.