AnsweredAssumed Answered

Easy Fix to Slow Performance:  Windows Power Settings

Question asked by Peter Medina on Sep 6, 2013
Latest reply on Oct 23, 2015 by Peter Medina

I'm sure that this topic/solution has been covered time and time again.  However, here's visual confirmation of how big the impact can be on performance. 

 

If you're having issues with slow performance in Solidworks, especially with the a new machine, or one of the architectures out there that have very low energy saving power states, you will need to make sure that the power setting in your OS is setup for HIGH PERFORMANCE.  This can be found in Start->Control Panel->Power Options

 

In my situation, I was having some slow rebuilds on a very new Overclocked system and by checking benchmarks, the results weren't making sense.  The machine is an i5-3570k, Win7-64, Solidworks 2013.  The OS was setup in POWER SAVER.  This meant that the processor would downclock to an energy saving state.  In this example it was idling at 1600 mhz and when the demand came up, it would clock up to 4600 mhz.  This sounds good in theory, but the performance hit is pretty big.  Even though it is clocking up to the fast speed eventually, the transient time it took to get to that speed was impacting every little feature in Solidworks' operation.  Now that the Setting is HIGH PERFORMANCE, the processor is almost always at the max frequency of 4600 mhz.  The impact on laptops will be very significant, especially since their power settings can change depending on whether or not it is on battery on plugged into the wall.  Windows settings CAN have a big impact on what is already good hardware.

 

Here's the times when running Anna's Punch Tool Benchmark with POWER SAVER enabled:

 

swx2013_PunchHolder_44ghz.JPG

 

Here's the times when running Anna's Punch Tool Benchmark with HIGH PERFORMANCE enabled:

 

sw2013_PunchHolder_46ghz_ssd.JPG

 

It is nearly a 100% hit on potential performance. 

Outcomes