2 Replies Latest reply on May 16, 2013 6:22 PM by James Pepper

    "Attached; Missing information" error

    James Pepper

      Hello everyone,


      I just received a new Windows 7 machine, my old PC was XP. I'm the EPDM Admin.

      I can access the Admin tools but I can't create a vault.


      Running "Setup View":


      Step 1 succeeds (connecting to an archive server).


      Step 2 will not allow me to "Select vault(s)". There is no checkbox.


      The dialog says "Attached; Missing information."


      When the network admin ran Setup View with his credentials, he was able to create a vault in my document folder and it worked as expected. However, because it was created under his credentials, I was unable to access the vault. He temporarily gave me Admin rights, but still no luck.


      Has anyone seen this? I've only found two references to it and the suggested fix was editing the Registry, which my network admin hasn't tried yet.



        • Re: "Attached; Missing information" error
          Charley Saint



          This is a somewhat common issue that occurs most often when someone attempts a "clean install" of SolidWorks during an upgrade by deleting the SolidWorks key from the registry which inadvertently breaks EPDM, but it can happen for a myriad of reasons. Two things can cause this issue, the registry keys are there but you can't see where the vault view is located, or the vault view is there but the registry keys are missing. If the registry keys for the vault are there then the only fix is editing the registry as suggested, if they aren't there and you just have a view attached it's a bit more complicated and you should contact your VAR for assistance removing it.

          • Re: "Attached; Missing information" error
            James Pepper

            Fixed it!


            The cause was this:


            I received a Windows 7 PC. I copied my entire Documents folder from my old XP machine, including the Vault folder.


            That somehow hosed the View Setup process.


            The fix was to simply delete the Registry key that referred to my Vault folder:


            [HKEY_CURRENT_USERS\Software\Solidworks\Applications\PDMWorks Enterprise\Vaults\[vault name]


            Then I ran View Setup and it installed my Vault folder as expected.