9 Replies Latest reply on Oct 24, 2017 10:57 AM by Hans Lankhaar

    BMP. image changes to Link when saving to .dwg

    Rick McDonald

      I don't know what setting I changed but I know I did because I did not previously have this problem with the same file/template.


      Here it is:

      I have a template that has a .BMP file of our company logo.

      When I open the template and create a drawing in SW it shows perfectly.

      If I send this file to someone else it also shows perfectly.

      However, when I do a save as to save the drawing as a .dwg file the bitmap image turns into a link.

      I have tried to open the .dwg in AutoCad and DraftSight and I see the same condition.

      When I send the file to another person it also shows as a link only.


      I know it is not the sheet format, sheet or template because I had another person send me their copy of the template (that works fine on their system) and it will have the same problem.


      I tried to simply insert a new .bmp into the template while opened as sheet format and again it will become a link when converted to dwg.

      I sent the same template back to another person (with the .bmp files inserted) and they then saved it as a dwg and it worked fine.
      This all tells me it is something on my system (not the file) that only stores the link instead of the bmp file image when making a .dwg.


      If I click on the link in the .dwg I can open the original .bmp without problems (but this .bmp file shows as being located in a temporary folder on my system, not in the file).


      Attached are screen snips of the file (while opened as a sheet format) in SW and then after saved as .dwg in DraftSight.


      I can not find any settings to change from saving .bmp as a link or saving as the actual .bmp.

      I have imported other files and then saved as .dwg and they do the same thing.

      I have tried to change the save as settings to different versions of AutoCad (R14, 2000-2002...)


      It seems that it has to be something in the Save as function.

      I am running SW 2012, SP2, Standard version, Windows 7 64 bit.

      Any suggestions ?


      Message was edited by: Rick McDonald I have also tried to insert a picture using the Insert> Picture command as was suggested in some earlier posts.

        • Re: BMP. image changes to Link when saving to .dwg
          Jerry Steiger



          I'm pretty sure that I saw someone else reporting the same behavior within the last couple of weeks and getting a response that this is due to the way AutoCAD handles images, but I can't track down the thread. As I recall, the way to fix the problem was on the .dwg or .dxf side, using DraftSight. Perhaps you changed some settings in DraftSight? Maybe you can find the answer using the forum Search; I couldn't, but I didn't try very hard.


          Jerry S.

            • Re: BMP. image changes to Link when saving to .dwg
              Rick McDonald

              I still have not been able to resolve this but I know it has to be a configuration or setting on my system.

              I can take my template files or make a SLDDRW drawing of it and send it to others and they see the logo fine.

              If they convert it to a dwg and send it to me, I can see the logo fine.

              If I save as dwg, the logo turns into a separate bmp file and the link image shows where my logo should be.

              Every test shows that it has to be something on my system when I convert it to DWG.


              I did see a different discussion from a year ago where someone had the same problem and there was never a correct answer.


              In that discussion the only 2 suggestions were to be sure the logo was on the Sheet Format (not the sheet) - his was as mine is, and to change it into vector graphics.


              I have tried to change many settings (anything that looks even remotely like it had a connection) with no luck.


              Anyone else here can take my format or a drawing I create from it and it works fine and then if they convert it to .dwg and send it to me I can read it fine as dwg.


              It has to be something in my conversion from .SLDDRW to .DWG.


              I hate to think I will not be able to insert .bmp files into my drawings if I need.


              Any advice or things to try would be welcome.

              It appears to be one of those things that happens rarely but it happens and over more than one version of SW.

              I am using 2012 SP2 standard,  Brad (from the linked post above) was using 2010.

            • Re: BMP. image changes to Link when saving to .dwg
              Rick McDonald

              I have now gone a step further and used the Copy settings wizard to restore all my settings to the original condition.

              Still didn't fix the problem.


              Fortunately I saved the original settings as well as the settings just before reverting back so I could come back to my preferred settings easily again.

                • Re: BMP. image changes to Link when saving to .dwg
                  Jerry Steiger



                  You might try using another user account on your computer to see if the .dwg conversion works properly there. That might give you a clue as to where the problem lies.


                  Jerry S.

                    • Re: BMP. image changes to Link when saving to .dwg
                      Rick McDonald

                      Good point,

                      I will have to check that and will update with my results.



                      I only have my primary user account on my work station and I don't want to mess any of that up now so I decided not to attempt this now - but it is a good suggestion and if anyone else has the same type problem I hope you post the results for the rest of us, so this strange problem may be resolved.

                      I have seen several people report the same type problems over about a 5 year period and NONE have had the problem resolved by SW or computer settings.


                      I have also followed the rest of those people that had this problem and converted my .BMP logo to a different format.


                      I actually used InkScape (free image edit Program), converted my .bmp image to vector graphics and then saved that as a .dxf and used Draftsight to edit the .dxf to do a solid fill and ultimately saved a a block for inserting into drawings.  Fortunately I was working with a simple logo.

                      I probably could have stopped at the .dxf or saved as a different vector image but decided to do this for easy import as .dxf into the parts themselves if needed.


                      After changing my .bmp to the block in my templates it worked fine.


                      Just wish SW could fix this in some way. It only seems to be an occasional problem but it could suddenly show up on anyone's computer as it did mine and it is a real headache to do the workaround.

                      It also means that I can never insert a .bmp image in any of my drawings as I have done in the past where I could download a simple image of a part or show the part in a finished assembly for reference.


                      Message was edited by: Rick McDonald

                  • Re: BMP. image changes to Link when saving to .dwg
                    Marco Mintchev

                    Hi Rick,

                    I have identical problem. I have asked my VAR but they couldn't help. I wonder if you ever found a solution?




                    • Re: BMP. image changes to Link when saving to .dwg
                      John Sadler

                      This was happening to me, only me, out of all of my coworkers.

                      Our IT guy spent 3 days to figure out the problem...Windows registry.


                      1. In Windows Start menu, search “regedit” and click “regedit.exe”
                      2. Navigate to HKEY_CURRENT_USER\SOFTWARE\Classes
                      3. Delete .bmp folder
                      4. Restart computer.

                      This is the ONLY thing that worked for me, but it worked.