6 Replies Latest reply on Jun 5, 2012 11:55 AM by Alison Hilditch


    Alison Hilditch

      Hi everyone,


      I have a MASSIVE problem that is completely stumping me and the IT guy. EPDM Administration, our Vault, AND Solidworks are all simply not responding.


      For Administration:

      The program opens and asks for the admin password. After inputting the password, Administration immediately grays out and throws the (Not Responding) next to the program name in the tab toolbar.


      For the Windows Explorer Vault View:

      I click on Vault and it immediately goes into "thinking mode". After about a minute, windows explorer goes into (Not Responding) Mode.


      For SolidWorks:

      SolidWorks opens correctly, I can access all dropdowns until I click on anything that inspires an action, unless I open from windows explorer. Goes into (Not Responding) Mode.


      We think that there may be an error server side, but we are having trouble pinpointing the issue. Has anyone encountered anything like this?


      I recieved an error this morning that EPDM could not log on to the database because "A communication link failure occured when accessing the database server. The database service might have been restarted or the network might be down." There was a discrpancy in the Object name of the database that EPDM was looking for (which was an odd occurance in itself since I've been working all month with no issues what so ever and only 2 people have clearance to edit the vault name) that was easilly fixed this morning. All programs began to function normally. 4 hours later, our current problem started.


      We are positive that the network is up and running and the server never restarted.


      The other SolidWorks users in the building are having no issues what so ever with SolidWorks. EPDM is on their computers, but as I'm setting up out new Vault they do not access it or interact with it in anyway. This problem is happening only on my laptop and Mr. IT's computer.


      We are running Solidworks Premium 2012 SP1.0 and Enterprise PDM 2012


      I would be estatic and thankful for any and all help!

      Thank you!


        • Re: EPDM is NOT RESPONDING!
          Tim Webb

          Just spitballing here: Your laptop has probably had a group policy enabled by IT today to block certain ports on your computer. I experienced this last week when IT rolled out a new policy and nobody could run SolidWorks or log into EPDM.


          They disabled the policy and connection was restored. Ports 25734 & 3030 are the important ones.


          No sure if this helps but is exact scenario happened to me last week.

          • Re: EPDM is NOT RESPONDING!
            Alison Hilditch

            Okay! So as far as fixes go, the good 'ol fashioned "reboot like mad" seemed to clear up the issue. Though everything seems to be in working order, I am still going to try to determine what happened so I can prevent it in the future. My company shares a server with another company in a different time zone and I would rather not have to keep restarting the server.


            Thanks for the input! I'll update on what I find.

              • Re: EPDM is NOT RESPONDING!
                Kishore Garakipati

                One more method that could be useful...!!


                Did you tried checking the performance of your SQL DB Server? You could have your IT doing a periodical check on the SQL DB Server performance using "SQL Server Profiler" where you could track the processing time for each of the events (actions) that each user would do.


                The SQL server profiler available with SQL management studio is very good utility or tool that would give us an opportunity to track the events related to the EPDM DB server, database, stored procedures and many more.


                If we were able to find out which exact event or action is the reason for the bad performance, we could do reverse engineering and find out the root cause.


                Please have your IT give a try when you get into issue the next time and let me know if you need some more help in this regard.



                  • Re: EPDM is NOT RESPONDING!
                    Alison Hilditch

                    Thank you! I brought your suggestion up to IT and we started looking at performance data and some super sluething led up to find out that our SQL was erroring out and causing problems when our Symantec system back-up software tried to back-up our data. Symantec works fine with our M2M and other databases, but for some reason it gets cranky with EPDM. So we removed our EPDM SQL from that particular back-up and haven't had an issue since!