19 Replies Latest reply on May 13, 2011 6:27 AM by Scott McFadden

    "Unable to open design table using excel 2003"

    Mathew Stevenson
      We just installed EPDM SP2 with our VAR and we are using SW SP2.1 with excel 2003 but every time we check in or just place a SW file into the vault and then try to open the design table we get "Unable to open design table using excel 2003". Has anyone had this issue? SolidWorks and the VAR are lost as this time
        • "Unable to open design table using excel 2003
          Deepak Gupta
          Mathew save the copy of the DT and try opening it. Also are you getting error in opening another excel files also.
          • "Unable to open design table using excel 2003
            Thanks Mat you ran me other with the bus, (VAR above mentioned). Just so it is posted here for all to find and and help is the Anti-Virus.
            We Disabled the Anti-Virus for a few minutes and all works well. Turn it on and the error comes back.
            McAfee VirusScan Enterprise 8.5.0i
            Scan Engine Version (32-Bit) 5300.2777
            DAT: 5547.0000
            There is be some work to figure out what the setting is in McAfee that is causing it, maybe Mat will post it later. I would but my legs hurt from being run over by the above bus. (All kidding aside).
            There seems to be some strange issues with McAfee and the SolidWorks Enterprise PDM vault. May be just settings, but this seems to be the only Anti-Virus that they are having problems. So if you are having a strange issue with Enterprise disable your McAfee and see it it resolves the issue. If it does, you know to start looking at the settings in the Anti-Virus one at a time until you no longer have the problem.

            Note: Mat and I are friends still.
            Have a great day.
            Mark Arnett
              • "Unable to open design table using excel 2003
                Mathew Stevenson
                Disabled the Anti-Virus is correct. The VAR did his magic and came to the rescue.

                Now my management will stop threatening my job over this and the VARs and SolidWorks understands the stress this gave me. Can we all say thank god!!!!!!!!!!!!!
                • "Unable to open design table using excel 2003
                  Erik Armstrong

                  I've been having the same problem as well. How did you determine that McAfee was causing the problem? I'm running Trend Micro Client/Server Security Agent for Windows 2003/XP and I'm not sure if that is causing it. I'll have to have the IT guys disable it to test as the disabling is password protected..

                  Also, wondering if this might be an issue with the specific build of SW, I'm running 2009 x64 SP2.1 on WinXP64.

                  Thanks for any help you can offer.
                    • "Unable to open design table using excel 2003
                      Mathew Stevenson
                      Anti-Virus turned off is not to be the problem after all.

                      Issue we have more in detail:

                      We opened the original file and it works. If you make a new-new file and try to open the design table, it doesn't.

                      1. Start SolidWorks.
                      2. Open the design table. It opens.
                      3. Save file into the vault
                      4. The design table doesn't open. (you have seen all of this) Now onto 5.
                      5. Close SolidWorks or just the saved file and close the file only
                      6. Open the saved file
                      7. Open the design table and it opens? With or without the virus software on.

                      See, we were opening the same file but that's not it, its only new files saved into the vault? If you close the file or SolidWorks, the files design table opens without any problems the next opening of it. I even have tried the check-in the out but still no luck until you close the file.

                      Our I.T. department upgraded the virus software, uninstalled it, and even just turned it off (disabled from admin) and the above still will not open the design table on newly created parts.

                        • "Unable to open design table using excel 2003
                          Erik Armstrong

                          We haven't yet installed EPDM here, but still having the same problem. I seem to have figured out a temporary work around at least. When I have the design table open to make changes or what not, as long as I just close the excel window after I'm done and don't click the save icon on the excel toolbar, then the design table will open the next time. But if I click to save it, then close it, it won't open the next time unless I completly close down SW and restart everything. Clicking the save icon isn't neccessary, but at first I figured it was, but any changes made are retained if you just close the window without clicking save...

                          Good Luck,
                            • "Unable to open design table using excel 2003
                              Mathew Stevenson
                              You don't need to save the excel design table after editing it. Maybe if you link to it but it works like MS Access
                                • "Unable to open design table using excel 2003
                                  Mathew Stevenson

                                  1 .I tried the copy an existing SolidWorks file (SWF) from explorer into the Vault and opening the file. The design table (DT) opens.

                                  2. I tried the right click open SWF from the vault to place the file into it's folder in the vault then opened the SWF in SolidWorks. The design table (DT) opens.

                                  3. I tried a NEW *.prtdot from the vault and it will also open the DT

                                  It's only issue is below.

                                  New file opened from a NEW *.prtdot file and save-as the *.sldprt into the vault. With the file still opened and never closed, the DT does not open. The *.prtdot was never in the vault and is not pulled from the vault.
                                  Open an existing *.sldprt from outside of the vault and then do a save-as into the vault, the *.sldprt will not open the DT.

                                  This is a SolidWorks and/or an EPDM bug, but now knowing all of this, we can use Enterprise PDM (EPDM). We just need to watch what we do until SolidWorks fixes this. We just need to copy from explorer to the vault before we open anything and/or just use the template files (*.prtdot) from inside the vault only.

                                    • "Unable to open design table using excel 2003
                                      Matt Couchot
                                      I think I found the solution... but I don't know if it's to your problems.

                                      I couldn't get design tables to open any more, under any circumstances. All I would get is that "Unable to open with Excel 2003" message.

                                      This happened right around the time that outlook would no longer use Word as my email editor, right after the time I uninstalled a shareware pdf viewer.

                                      As far as I can tell, the install or uninstall of the shareware was sloppy, and it messed up or unregistered a file that was needed for external calls to things like Word and Excel. Microsoft help suggested this fix:

                                      run from the command line:
                                      Regsvr32.exe %Windir%\System32\Ole32.dll

                                      Boom! Outlook could call on Word again. But SW design table calls to excel were still broken. But I am running 64 bit SW, so I thought I might have the wrong directory.

                                      So I ran:
                                      Regsvr32.exe %Windir%\Syswow64\Ole32.dll

                                      Boom! SW can use excel for design tables again. (after I closed and reopened SW)
                          • "Unable to open design table using excel 2003
                            John Zhao
                            I had the same problem all the time, but recently I found one thing it might be the cause of the problem, that is when you close the design table from the solidwork it looks the OLE Excel is close but some time when you open the service window by use Ctrl+Alt+Del, you will find the Excel.Exe. is still there, that means the OLE Excel did not quit from the sytem, so when you try to open the design table again , they would not allow you to do so because previous one is still in the service. So now I will check the service if solidworks not allow open the design table. It works, I have report the case to VAR and solidworks, hope they will look at it.
                            • Re: "Unable to open design table using excel 2003"
                              Corey Vantilborg



                                 It looks like your testing has already ruled this out but we ran into a similar issue with Excel 2007 and design tables.


                                 What we found was that if you used the Solidworks Add-In to check-out the file, then you could not access the Excel with the same error you get.  However if you checked out that same file from explorer or the search tool then opened in Solidworks everything works correctly.


                                  I think that saving a file for the first time from Solidworks also caused the issue.



                              Corey V

                              • Re: "Unable to open design table using excel 2003"
                                Matthias Stiller

                                There is a (known) problem with SWx2009 and Excel2003 in a 64bit environment.

                                But your VARs should know this!

                                We changed to Excel2007 to fix this.

                                With SWx 2010 and "early" SPs you have the same problem, but since SP4 (not sure) it's fixed.


                                Hope I didn't misunderstood this thread...