Glenn Schroeder

I got an error message when I tried to open a SW file.

Blog Post created by Glenn Schroeder on Jan 11, 2018

Of course if you have a backup try opening it.  If you don't then try opening the file with a different method.  I typically open files by selecting them from Windows Explorer, but when getting that error I can usually open the file by going to File > Open and browsing to and selecting the file that way.  You might also try just clicking on the file in Windows Explorer and dragging it into the SolidWorks window.

 

 

If none of that works, right-click on the file in Windows Explorer and choose "SOLIDWORKS > Pack and Go..." (assuming you have SolidWorks Explorer installed).  That will open up the Pack and Go dialog box.  Save the file to a different location and try to open this new one.  If it opens okay you can save it over the original, or just continue working with it in the new location.

 

 

If this still doesn't work, you may have to send it to your VAR to see if they can help, or you could try posting it on the forum in a new Discussion (please don't do it here) to see if someone else can open it, save it, and send it back.

Outcomes