I've seen a number of Discussions here on the Forum about problems when the Windows icon scale is set to anything other than 100% (especially larger, see My layer properties window is not showing the columns for Active layer and On/Off and 2015 Smart Dimension in Sketch Defaults to Dimension ID Entry for just two examples), so if yours is set to something else try switching to 100% and see if that helps.  I believe this is mostly related to not all options being displayed in Property Managers, and in right- or left-click menus.

 

If that's not the case, it's very likely to be a problem with your graphics card.  I am by no stretch of the imagination a hardware expert, but from reading posts here on the forum for years I feel confident in saying that if you have weird graphics issues, and your icon scale is set to 100%, the problem is probably related to your graphics card.  The wrong graphics card, or the wrong driver for the right card, can cause an extraordinary number of strange issues.  Since Windows 10 came out I seem to have seen more issues reported here, and many of them seem to have come from automatic Windows updates, which include graphics card drive updates, causing problems.  Reverting to the previous driver often seems to fix the problem.

 

Some people use unapproved cards with no problem, but if you're having issues you apparently aren't lucky enough to be one of those.  If you have a company IT person that spec'ed your new machine with a high end gaming card because he/she just assumed it would work well with SolidWorks, you have my sympathies.  Get an AMD FirePro or an NVIDIA Quadro (which is what I use) for best results.  If you already have one of those, check here to make sure you have the correct driver.  The newest driver isn't necessarily the one that works best with SolidWorks.  You might also run the SolidWorks Diagnostics tool at Start > All Programs > SolidWorks 2015 (or whatever year) > Tools > SolidWorks Rx > Diagnostics to see what that shows.

 

If you have a GeForce card, and it was working fine but stopped, it's probably because of an automatic driver update.  See here.

 

If you're stuck with a non-approved card, and nothing else works, try selecting "Use software OpenGL" as shown below (Tools > Options > System Options > Performance).  If it's grayed out so you can't select it then close all SW files and try again.  I don't have any experience with this, but I understand that it helps sometimes.  If nothing else, while you may not want to use this long term, if your issues go away while using it then you'll know the problem does lie with your graphics card, so it can be a useful diagnostics tool.

 

 

2018-05-25 edit:  I've seen several Discussions on the forum recently from people that were using an unapproved graphics card with no problems, and then Solidworks completely stopped working.  It seems that a driver update was the culprit most, if not all, of the time.  So if that's your situation you might try rolling back to the previous driver.