Glenn Schroeder

How do I change my units from inches to mm (or vice versa)?

Blog Post created by Glenn Schroeder on Dec 23, 2017

For a quick change you can go to the bottom of your monitor and make the change with the flyout.

 

 

This flyout is a fairly recent enhancement.  If you're using an earlier version that doesn't have it go to Tools > Options > Document Properties > Units. If you do have the flyout you may need to go there anyway to refine some settings.  Below is a screenshot of the settings for my drawing template.  Dimensions display as inches because "IPS (inch, pound, second)" is selected, and they're rounded to the nearest 1/16 because I entered 16 in the Fractions column.  You can enter 8, 32, or whatever is appropriate for your drawing.  When I took the screenshot I had clicked on the cell in the More column to show the fly-out.  If you have similar settings, but an occasional dimension displays as decimal instead of fraction, then it's because you don't have "Round to Nearest Fraction" selected.

 

 

If you want your dimensions to show as decimals instead of fractions, then click on the drop-down arrow in the Decimals cell and make the appropriate selection for the number of digits you want to display.  (I almost always choose 4 digits because it bothers me to no end to see 1/16, 5/16, etc. rounded off, but that's just a personal quirk.)

 

 

If on the other hand your drawing is displaying inches and you want millimeters, change the setting to "MMGS (millimeter, gram, second)" at top and choose the appropriate number of decimals you want to show from the Decimals column.  If you want your dimensions rounded to the nearest millimeter you'd select "None" from the drop-down.  If you want something that's not a standard Unit system, such as feet and inches, then select "Custom" and make your selection from the drop-down in the Unit column.

 

By default, even if you have something other than "None" selected in the Decimals column and a dimension is an even millimeter, (inch, etc.),  then the zeros past the decimal point won't show.  If you want them to show, then go to Tools > Options > Document Properties and select "Show" from the drop-down shown below.

 

 

If this change is something you want for future use be sure to save it in your document template (see Why aren't the changes I made at Tools > Options > Document Properties saved when I start a new Part?).

Outcomes