Skip navigation
All Places > FAQs (Frequently Asked Questions) > Blog > 2017 > December > 24

With the Smart Dimension function active, hold down your Shift key while selecting the circle.  That will place the dimension to the edge (near or far edge, depending on where you click) instead of the center.  I've occasionally run into situations where I need to reference two arcs or circles with one dimension, such as a slot length, and holding down Shift would only place the dimension to the edge of one of the arcs and the other one would still go to the center point.  When that happens I just accept it, and then change it to Max (see below).

 

If you already placed the dimension, you don't need to delete it.  Just click on it to highlight it and bring up it's PropertyManager, then go to the Leaders tab.  Center will be selected by default, but you can change it to either Min or Max, depending on your needs.  The screenshot below is from a sketch in a Part, but the same principles work with dimensions in a Drawing.

 


This assumes that you were referring to placing a dimension with the Smart Dimension function in a Drawing, or in a sketch in a Part or Assembly.  If you're using the Measure tool from the Evaluate toolbar and want to measure to the edge of a hole or circle instead of to the center, then click on the Arc/Circle Measurements icon and choose the appropriate setting from the drop-down.  Keep in mind that while Center to Center is the default setting, SW will remember your last setting the next time you activate the tool.  It won't go back to the default.

 

Yes.  Expand your Cut list folder all the way down to the body name.  Right-click on it and Material should be there in the drop-down menu.  After that it works just like selecting Material further down in the tree.  If it's not there, then just like on pretty much every other SolidWorks right-click menu click on the little double-arrows at the bottom to get all available options.

 

With the Smart Dimension tool active, right-click on one of the edges and choose "Find Intersection" from the drop-down.

 

 

Then left click on the second edge.

 

 

That will insert a Virtual Sharp at the intersection of the two edges, and establish it as the dimension reference.

 

 

Now you can choose the second reference to place the dimension.

 

 

This workflow is a fairly recent enhancement (SW2015, maybe?). If you're using an older version then exit the Smart Dimension function, Ctrl+select the two edges, and then select the Point sketch tool. That will place a Virtual Sharp at the intersection of the edges, and now you can dimension to it.

 

By the way, you can choose which of several styles you prefer for Virtual Sharps at Tools > Options > Document Properties > Virtual Sharps.

 

 

Unfortunately, there isn't currently (as of SW2019) a way to set a default Layer or color for them in Document Properties. You can assign a Layer to them after they're placed if you don't like the default.

I, or someone else, will be glad to help.  Most of us here enjoy helping others learn more about SolidWorks, and some active forum members are teachers.  I can't speak for others, but while I've learned a tremendous amount here, and am still learning, now I mostly just enjoy giving back and helping other users.

 

Now that I have that out of the way, we need you to help us to help you.  Please post a specific question in the Discussion section of the Forum (or in a Reply to your existing Discussion if you were sent here) about what part of your assignment you're having trouble with.  Vague pleas like "Please help", with a screenshot of the assignment, probably won't get much response.  Include screenshots of your work at a minimum, and attaching your model will be better (see How can I attach a file to a forum post? for instructions).  As Kevin Chandler replied to someone that asked for help without showing any effort: "Our enthusiasm is directly proportional to your initiative."

 

If, on the other hand, instead of help you want someone to do your work for you, please don't bother asking.  It's dishonest, you won't learn anything that way, and we have better things to do with our time.  You may find yourself the victim of biting sarcasm, or something like this could happen.

 

Edit:  By the way, if you were sent here and you aren't a student, the above probably still applies.  Give us some more information, show some effort, etc.

Some features allow Equations and linking directly in the Property Manager. (See 2018 SOLIDWORKS Help - Direct Input of Equations in PropertyManagers for the list.) It's as simple as typing the Equal sign in the dimension box to get the drop-down where you can make your selection. See below from a Linear Component Pattern in an Assembly.

 

 

This hasn't always been the case, and still isn't available for all features that use a dimension, but it can still be done. If you can't do it directly in the Property Manager go ahead and create the feature, using a value that's close to what you need, and click Okay to close the feature. Now there are two options for linking the dimension.

 

1. Single-click on the feature in the tree to show the dimension in the graphics area (or double-click if you don't have Instant 3d turned on).

 

 

Double-click on it to bring up the standard dimension dialog box, enter the Equal sign, and you'll get the same drop-down shown above. You'll need to do a manual rebuild for the change to take effect.

 

 

..or option 2: Open your Equations dialog box and go to the "Dimensions" tab. All dimensions in the model will be listed. Remove the value in the "Value / Equation" column and enter the Equal sign. That will give the same options for linking. (Naming dimensions will be a big help if you want to use this option. That will make it much easier to find the one you need.)

 

 

 

By the way, I believe in giving credit where it's due. I learned about this second option from Frederick Law at Global variables in "Thicken" feature?.

When you make changes to the Document Properties those changes only affect the active document.  If you want to apply them to new Parts then open a new blank Part and make the desired changes.  Go to File > Save, and choose Part Templates (*.prtdot) from the drop-down at "Save as type:".

 

 

Name the file appropriately and save.  I described the process for saving a Part template, but it's the same for Assemblies and Drawings.  Just choose the appropriate template type from the drop-down.  I'd strongly suggest saving templates (and sheet formats, and weldment profiles,etc) somewhere other than the default location in the SolidWorks installation folder so you won't lose them if you upgrade to a newer version.  If you're in a multi-user environment you might want to save them on a network so they're available for other users.

 

Next go to Tools > Options > System Options > File Locations > Document Templates.

 

 

 

 

Click on the "Add..." button, browse to the folder where you saved the template, and select it.  I'd suggest deleting the default location that's there now, but that's up to you.  Now when you start a new Part you should have the new template available to choose from.  If you don't, and you see this...

 

 

 

...which only has the default templates to choose from, click on the "Advanced" button at lower left.  Then it should look something like this:

 

 

You only see one Part and one Assembly template here because that's all I have saved.  Depending on your needs you can certainly have more.  Just name them appropriately so you know what you're choosing.  If you have a large number of document templates you can add sub-folders at the location you're pointing to at File Locations > Document Templates, and these sub-folders will show up as tabs in the Advanced New Document dialog box.  See above.  "Templates" is my main folder that contains my most used templates, and "Other Drawings" is a sub-folder that contains some drawing templates that I rarely use but don't want to get rid of.

 

While I'm on the subject, occasionally someone will ask how to apply new Document Property settings to an existing document.  You can open a document with the desired settings, go to Tools > Options > Document Properties > Drafting Standard, and select "Save to External File...".  Save this standard, then open the model or drawing you want to update, go to the same location, choose "Load From External File...", and Browse to and select the desired saved standard.  I haven't used this much, and have gotten mixed results when I did, but it's worth a shot.  If you're in this situation I'd encourage you to go to Drafting standard refusing to change. Dimension Styles not loading in automatically and view font not changing. What am I doing wrong? .  The first part doesn't pertain to the subject here, but about halfway down (starting with post #7) Dan Pihlaja entered the conversation with some good information.

 

 

For Drawings, another option is to open the existing Drawing, then start a new one with the new Template, and copy sheets from the existing document and paste them into the new one.  This isn't a perfect procedure either, since it doesn't save all the Document Property settings, but it might work for you.

For a quick change you can go to the bottom of your monitor and make the change with the flyout.

 

 

This flyout is a fairly recent enhancement.  If you're using an earlier version that doesn't have it go to Tools > Options > Document Properties > Units. If you do have the flyout you may need to go there anyway to refine some settings.  Below is a screenshot of the settings for my drawing template.  Dimensions display as inches because "IPS (inch, pound, second)" is selected, and they're rounded to the nearest 1/16 because I entered 16 in the Fractions column.  You can enter 8, 32, or whatever is appropriate for your drawing.  When I took the screenshot I had clicked on the cell in the More column to show the fly-out.  If you have similar settings, but an occasional dimension displays as decimal instead of fraction, then it's because you don't have "Round to Nearest Fraction" selected.

 

 

If you want your dimensions to show as decimals instead of fractions, then click on the drop-down arrow in the Decimals cell and make the appropriate selection for the number of digits you want to display.  (I almost always choose 4 digits because it bothers me to no end to see 1/16, 5/16, etc. rounded off, but that's just a personal quirk.)

 

 

If on the other hand your drawing is displaying inches and you want millimeters, change the setting to "MMGS (millimeter, gram, second)" at top and choose the appropriate number of decimals you want to show from the Decimals column.  If you want your dimensions rounded to the nearest millimeter you'd select "None" from the drop-down.  If you want something that's not a standard Unit system, such as feet and inches, then select "Custom" and make your selection from the drop-down in the Unit column.

 

By default, even if you have something other than "None" selected in the Decimals column and a dimension is an even millimeter, (inch, etc.),  then the zeros past the decimal point won't show.  If you want them to show, then go to Tools > Options > Document Properties and select "Show" from the drop-down shown below.

 

 

If this change is something you want for future use be sure to save it in your document template (see Why aren't the changes I made at Tools > Options > Document Properties saved when I start a new Part?).

I can't tell you why it's wrong, but I can help you fix it.  Edit the feature and click on the blue arrow at the top of the feature's PropertyManager (it's pretty easy to overlook).

 

 

That will take you to the second page of the PM, where you'll get a preview of the Mirror, and you can select which orientation you want.  Below is the default in the Mirror I used for the example.

 

 

When I clicked on the double caret at right in the box this is what I got.

 

 

If you've mirrored multiple components you may need to click on each one in the Orient Components box and fix each one.

If this is in an Assembly, you likely have a small Part that's a good distance away from the rest of your Assembly.  Click-and-drag a box on the apparently blank space to select anything that's out there, even if you can't see it, then hit the Delete button.  Now try Shift+C again to see if that fixed the problem.  If that doesn't work check your sketches to see if there's a stray sketch element or dimension out there.  If you have a sketch out in space, but have sketches set to Hide, Zoom to Fit will still act like the sketch is visible, and perform accordingly, unless the sketch is set to Hidden in the tree, so you might check that also.

 

These are only a few of the possibilities; there are others.  If the click and drag box and Delete doesn't work, try suppressing components, and any other features, and then try again to track down the problem. Something is almost certainly out there.

 

If it's in a Drawing you may have a small sketch element that's causing the problem.  Try the same method.  If this is a drawing view of an Assembly, with some components hidden, the drawing view outline will still encompass the whole model.  Do a Cropped View around the visible components.  That should fix it.  If you're using SW2015 or later you can use the Zoom to Sheet function instead of Shift+C (SolidWorks Help - Zoom to Sheet), which will ignore the drawing view boundary if it extends past the drawing sheet.

 

On a related issue, I saw a post on the forum from someone that had a feature dimension thrown way away from the model.  It turns out that the problem was caused by an infinite length construction line in the feature sketch.  When the user edited the sketch and removed the infinite length from the construction line the problem went away.  I haven't used infinite length construction lines in years so I haven't personally run into this problem, but wanted to pass it along.  By the way, it isn't necessary to fully define the endpoints of a construction line to have the sketch fully defined, as long as the line's position is fully defined.  That's why I never see a need to have them infinite length (plus it just bugs me to see them extending to the edge of my graphics area).

This is a broad topic, but I'll try to address several possibilities. One thing to keep in mind is that when you start a pattern or mirror feature, "Features and Faces" (red arrow below) will be selected by default, and the first box (Features to Pattern) will be active. See the screenshot below. You'll see why that's important further down when I discuss specific situations. Also, for some reason unknown to me, the number of instances (third box down from the top, with 2 in it) includes the seed that's being patterned, so in the example below one new feature would be created. The numeral 1 is there by default on some occasions. Again, I don't know why, since the feature won't work with 1 entered there.

 

 

  • If, for example, you're trying to pattern a single hole that was created as part of a pattern, and the software is trying to pattern all the instances instead of just the one you selected, that's because by default the first box under "Features to Pattern" was active. Clear that box and click in the one below it instead, then select the face of the hole. If it's a rectangular hole you'll need to select all four faces (or five if it doesn't go all the way through the body), etc.

 

  • Keep the "Geometry pattern" box in mind. When it's not selected then the pattern will use the same conditions as the seed. For example, if you're patterning a hole, and the hole was created with "Offset from Surface" as the end condition, then the patterned holes will maintain the same offset from the same selected face.

 

If that box is checked then the same exact geometry of the seed feature will be patterned, ignoring the end condition.

 

 

  • If you're working with a multi-body Part and trying to pattern a single body or combination of bodies, you'll get better results if you de-select the "Features and Faces" box and select Bodies instead, then select the body or bodies to pattern. Failing to do that is a common mistake. If that's the situation, and you've already created the pattern, you can edit it if you're using SW2015 or later. You'll need to un-check the Features and Faces box and clear it's selections, then proceed with Bodies. If you're using an earlier version you'll need to delete this pattern and create a new one, this time choosing Bodies instead.

 

  • If you've done that and it's still not working right, make sure this body hasn't been inadvertently merged with another body or bodies. Click on the feature that created the body, select the "Edit feature" icon, and make sure the "Merge bodies" box isn't checked. Since that box will often be checked by default that's also a common mistake.

 

Speaking of patterns, I never use sketch patterns. I've had better results with creating a single feature or body with the sketch, then patterning it. There may be situations where this isn't true, but I have never run into one. I know there are some people that are hung up on keeping the feature tree as short as possible, but sometimes it pays to have the extra line or two.

 

Mirroring sketch elements, on the other hand, usually works pretty well, and I do it often.

 

If none of these address your issue, feel free to post it on the forum as a new Discussion. Please include the Part when you do (see How can I attach a file to a forum post?).

Check the box shown below in the Feature's Property Manager, then choose All components or Selected components.  If you choose Selected components you will likely need to un-check the box for Auto-select, and then choose which Part files you want the feature to propagate to.

 

Also keep in mind that if you choose "All components" it will affect components that are added after the feature.  I found this out the hard way (it took me longer than it should have to figure out why my washer didn't look right after it was mated to the hole).

 

Yes, the Copy Settings Wizard will do that.  It will let you save a file with all your toolbars, menu selections, and other workspace settings, along with your settings at Tools > Options > System Options.  You can then go back to the Copy Settings Wizard to load these settings when needed.  While it's perfectly fine to save this file to your hard drive, I'd suggest keeping a backup on a network, flash drive, etc. in case your computer dies, or for when you get a new one.  And it doesn't automatically update, so to keep it current you need to save a file every time you make changes.  Please keep in mind that some experienced users recommend not using the Copy Settings Wizard to restore settings when upgrading to a new version, but instead set up everything manually.  I've personally never had any problems with it, but it's something to keep in mind.

 

There are several ways to get to it.  If you have SW open, you can go to Tools > Save/Restore Settings...

 

 

...or go to the SolidWorks Resources tab on the Task Pane and choose Copy Settings Wizard in the SolidWorks Tools section.

 

 

If you don't have SW open you can get to it by going to Start > All Programs > SolidWorks > SolidWorks Tools > Copy Settings Wizard.

 

To start off, you have to be in the Discussion itself. You can't attach files when replying to a Discussion from your Inbox (thank you Dan Pihlaja for pointing that out).

 

If you're attaching a Drawing or Assembly please keep in mind that you also have to attach all referenced files or we won't be able to open it, and don't post these files separately, but do a Pack and Go to a zip file and post that (see How can I create a new Assembly or Drawing similar to an existing one? if you aren't familiar with Pack and Go). If you're posting a Part file it's unlikely that you need to zip it first. Just post it directly. And don't attach .rar files. Very few people will open them. I know I won't.

 

Now that I have that out of the way, if this is in a Reply to an existing Discussion, click on the black text "Use advanced editor" in the right corner above the text box. I know it doesn't look like a link, but it is.

 

 

After clicking on that you'll get a link to attach files in the lower right, beside the "Mention" link shown above. Click on the "Attach" link and Browse to and select the file.

 

 

If instead of a Reply this is a Discussion you're just starting, the "Attach" link should already be there. If you've already posted the Discussion and would like to go back and add a file to the original post there's an "Edit" link under "Actions" to the right of your original post you can click on to get the "Attach" link back.

 

 

2018-09-12 edit: If you only want to attach a screenshot you also need to use the advanced editor to post a jpeg or similar file, but there's an easier way. My usual procedure is to hit the PrtScn/SyRq button on my keyboard to copy whatever's on my monitor. Next I open Paint and hit Ctrl + V to paste the screenshot. I use the tools in Paint to underline, point an arrow at something, etc, then use the Select tool to choose a specific area. Ctrl + C to copy it, then go to the open forum post and Ctrl + V to paste it directly in with the text. It's that simple. Other users have somewhat different workflows that I'm sure work just as well (and they're free to post theirs here if they'd like), but this one works well for me.

As with most things with SolidWorks, there are several ways to do this.  Select the one that works best for you.

 

I'll start with what I believe is the simplest, and the one I almost always use (I like simple).  When you've selected the model to insert in the drawing, go to the "Select Bodies..." button in the drawing view's property manager.

 

 

That will take you to the Part file where you can select which body, or combination of bodies, you want to show in the drawing view.  You can also use this feature to add or remove bodies from existing drawing views, not just when creating new ones.

 

Another method is to insert the drawing view, then right-click on an edge of a body you want to hide and choose Show/Hide > Hide Body.  If you want to get it back just find the body in the tree and right-click on it.  There will be an option in the menu to show it again.

 

 

A third option is to save out the bodies as separate Part files by right-clicking on the body and choosing "Insert into New Part..." from the drop-down.  A number of people use this method, but I don't think I've ever had a reason or need to.  If you have to have a separate Drawing for each body because of company standards then you should likely use this method, especially if you have title block notes that are driven by the Part's custom properties.  Unfortunately, at this time title block notes can't be driven by cut list properties. 

 

 

Still another option would be to create multiple Display States in your Part, hiding bodies in each as needed, and then reference the appropriate Display State in the Drawing.

 

Remember I said there are multiple ways to do most things in SolidWorks?  Here's the 5th.  Go ahead and insert a view, then right-click on it and choose Drawing Views > Relative View.

 

 

That will take you to the model, where you can choose which faces (or Planes) you want front and right, and you will also have an option to choose which body or bodies you want included in the view.  When you click OK in your model it will place a new drawing view oriented according to your selections.  You can now delete the original view if it's not needed.  Relative View was one method commonly used for showing selected bodies before the Select Bodies... button shown above was added.  I've rarely used it since then, but if you have a body at a weird angle, such as a brace, it can be very useful.

I've seen a number of Discussions here on the Forum about problems when the Windows icon scale is set to anything other than 100% (especially larger, see My layer properties window is not showing the columns for Active layer and On/Off and 2015 Smart Dimension in Sketch Defaults to Dimension ID Entry for just two examples), so if yours is set to something else try switching to 100% and see if that helps.  I believe this is mostly related to not all options being displayed in Property Managers, and in right- or left-click menus.

 

If that's not the case, it's very likely to be a problem with your graphics card.  I am by no stretch of the imagination a hardware expert, but from reading posts here on the forum for years I feel confident in saying that if you have weird graphics issues, and your icon scale is set to 100%, the problem is probably related to your graphics card.  The wrong graphics card, or the wrong driver for the right card, can cause an extraordinary number of strange issues.  Since Windows 10 came out I seem to have seen more issues reported here, and many of them seem to have come from automatic Windows updates, which include graphics card drive updates, causing problems.  Reverting to the previous driver often seems to fix the problem.

 

Some people use unapproved cards with no problem, but if you're having issues you apparently aren't lucky enough to be one of those.  If you have a company IT person that spec'ed your new machine with a high end gaming card because he/she just assumed it would work well with SolidWorks, you have my sympathies.  Get an AMD FirePro or an NVIDIA Quadro (which is what I use) for best results.  If you already have one of those, check here to make sure you have the correct driver.  The newest driver isn't necessarily the one that works best with SolidWorks.  You might also run the SolidWorks Diagnostics tool at Start > All Programs > SolidWorks 2015 (or whatever year) > Tools > SolidWorks Rx > Diagnostics to see what that shows.

 

If you have a GeForce card, and it was working fine but stopped, it's probably because of an automatic driver update.  See here.

 

If you're stuck with a non-approved card, and nothing else works, try selecting "Use software OpenGL" as shown below (Tools > Options > System Options > Performance).  If it's grayed out so you can't select it then close all SW files and try again.  I don't have any experience with this, but I understand that it helps sometimes.  If nothing else, while you may not want to use this long term, if your issues go away while using it then you'll know the problem does lie with your graphics card, so it can be a useful diagnostics tool.

 

 

2018-05-25 edit:  I've seen several Discussions on the forum recently from people that were using an unapproved graphics card with no problems, and then Solidworks completely stopped working.  It seems that a driver update was the culprit most, if not all, of the time.  So if that's your situation you might try rolling back to the previous driver.